Even Apple is climbing on the Windows 7 bandwagon.

Boot Camp, the Mac OS X utility that lets Mac owners run Windows in a separate partition, now requires Microsoft's newest operating system, the company said Monday in a support document.

All new installations of Mac OS X 10.7, aka Lion, are equipped with Boot Camp 4, which runs only Windows 7. The older Vista and even-creakier Windows XP do not work in Boot Camp 4.

According to Apple, Boot Camp 4 requires: "An authentic, single, full-installation, 32-bit or 64-bit Microsoft Windows 7 Home Premium, Professional, or Ultimate disc."

But Mac users who are upgrading to Lion or migrating an older pre-Lion machine to new hardware powered by Lion can retain the older Boot Camp 3 and thus the ability to run Vista or Windows XP, Apple said. Those customers cannot upgrade to Boot Camp 4.

"If your Mac has a Boot Camp partition with Windows XP or Windows Vista, you can continue to use your Boot Camp partition, but you can't upgrade to Boot Camp 4.0," Apple said in the online document.

Alternatives

Other users who want to run Windows XP or Vista on Mac OS X 10.7 can instead use virtualization software, such as Parallels' Desktop for Mac , VMware's Fusion or Oracle's free open-source VirtualBox .

Apple did not explain why it's barred Windows Vista and XP from Boot Camp, but the move essentially shadows rival Microsoft's own position: Only Windows 7 matters.

As it did two years ago with Internet Explorer 6 (IE6) , Microsoft has been running down Windows XP, telling users recently, "It's time to move on" as it urged them to abandon the OS for Windows 7.